Cloud Provider issues affecting our services

Incident Report for CloudBees

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:52 UTC

Monitoring

Some components might experience slowness due to issue with upstream Cloud Provider. We are working on mitigations
Posted Oct 20, 2025 - 10:19 UTC
This incident affected: CloudBees platform (CloudBees Platform, Workflow Execution).